Delays on ARS withdrawals processing

Incident Report for Bitso

Resolved

This incident has been resolved.
Posted Sep 26, 2025 - 22:06 UTC

Identified

Issue has been identified and fixed already. We are still working on the withdrawals that were affected during this case. We apologize for any inconvenience this may cause and appreciate your understanding. Be assured that the security of your funds remains our top priority at all times.

For further assistance, please contact our Customer Support team at https://support.bitso.com/

-----------------------------------------------------------------------

El problema ha sido identificado y resuelto. Aún estamos trabajando en los retiros que se vieron afectados durante este caso.
Lamentamos cualquier inconveniente que esto pueda causar y agradecemos tu comprensión. Te aseguramos que la seguridad de tus fondos sigue siendo nuestra máxima prioridad en todo momento.
Si necesitas más ayuda, por favor, contacta a nuestro equipo de Soporte al Cliente en https://support.bitso.com
Posted Sep 26, 2025 - 14:13 UTC

Investigating

We are currently experiencing delays on some ARS withdrawals processing. We appreciate your patience while our engineers work in this case.

We apologize for any inconvenience this may cause and appreciate your understanding. Be assured that the security of your funds remains our top priority at all times.

For further assistance, please contact our Customer Support team at https://support.bitso.com/

-------------------------------------------

Actualmente estamos experimentando demoras en el procesamiento de algunos retiros de pesos argentinos (ARS). Agradecemos tu paciencia mientras nuestros ingenieros trabajan en resolver esta situación.

Lamentamos cualquier inconveniente que esto pueda causar y agradecemos tu comprensión. Queremos que sepas que la seguridad de tus fondos sigue siendo nuestra máxima prioridad en todo momento.

Si necesitas más ayuda, por favor, contacta a nuestro equipo de Soporte al Cliente en https://support.bitso.com.
Posted Sep 26, 2025 - 13:20 UTC
This incident affected: Argentine pesos (ARS) 🇦🇷 (Bank Transfer (COELSA)).