Issues with https://bitso.com and https://bitso.com/alpha landing pages

Incident Report for Bitso

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 09:38 UTC

Monitoring

landing pages https://bitso.com and https://bitso.com/alpha are working now and we are monitoring .
Posted Dec 05, 2025 - 09:21 UTC

Investigating

We are having degraded performance on https://bitso.com and https://bitso.com/alpha landing pages. We are investigating . We will keep you posted .

We apologize for the inconvenience.

If you need further assistance, please get in touch with our Customer Support team at https://support.bitso.com/.
Posted Dec 05, 2025 - 09:10 UTC
This incident affected: Bitso Website 🖥 and Bitso Alpha 📈.