Delays with SPEI MXN Withdrawals | August 12th, 2025

Incident Report for Bitso

Resolved

This incident has been resolved.
Posted Aug 12, 2025 - 22:33 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.

-------------------------

Se ha implementado una solución, estamos monitoreando los resultados.
Posted Aug 12, 2025 - 21:59 UTC

Investigating

We are currently investigating an issue that is causing issues in completing SPEI MXN withdrawals. We have temporarily disabled withdrawals while we implement the fix.

We will provide another update as soon as we have more information.

We apologize for any inconvenience this may cause.

-------------------------------

Actualmente estamos investigando un problema que está causando que los retiros de SPEI MXN no se acrediten de manera normal. Desabilitamos de manera temporal los retiros mientras implementamos una solución.

Estaremos compartiendo actualizaciones en cuanto tengamos más información.

Disculpa las molestias.
Posted Aug 12, 2025 - 21:38 UTC
This incident affected: Mexican pesos (MXN) 🇲🇽 (Bank Transfer (SPEI)).